package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\[?([\w$#]+)]?\.)?\[?([\w$#]+)]?$`)
var str = `-- should match
schema1.MyProcedure
MyProcedure
[MyProcedure]
[schema1].[MyProcedure]
[schema1].MyProcedure
MyProcedure_V1234
[MyProcedure_Ver1234]
schema1.[MyProcedure#V1234]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}