re = /^(?:\[?([\w$#]+)]?\.)?\[?([\w$#]+)]?$/m
str = '-- should match
schema1.MyProcedure
MyProcedure
[MyProcedure]
[schema1].[MyProcedure]
[schema1].MyProcedure
MyProcedure_V1234
[MyProcedure_Ver1234]
schema1.[MyProcedure#V1234]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end