const regex = new RegExp('^(?:\\[?([\\w$#]+)]?\\.)?\\[?([\\w$#]+)]?$', 'gm')
const str = `-- should match
schema1.MyProcedure
MyProcedure
[MyProcedure]
[schema1].[MyProcedure]
[schema1].MyProcedure
MyProcedure_V1234
[MyProcedure_Ver1234]
schema1.[MyProcedure#V1234]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}