# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *(\n)?\s*#* *(\n)?\s*$//gm;t' <<< "## aaa bbb"