$re = '/ *(\n)?\s*#* *(\n)?\s*$/m';
$str = '## aaa bbb';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;