using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *(\n)?\s*#* *(\n)?\s*$";
string substitution = @"";
string input = @"## aaa bbb";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}