package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) *(\n)?\s*#* *(\n)?\s*$`)
var str = `## aaa bbb`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}