use strict;
my $str = '## aaa bbb';
my $regex = qr/ *(\n)?\s*#* *(\n)?\s*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";