#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(BAPN)|(NOBAPN)"
Local $sString = "D14 J4N4-BAPN_633nm_20x_100%_30accu_10s_point 1 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")