import Foundation
let pattern = #"(BAPN)|(NOBAPN)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"D14 J4N4-BAPN_633nm_20x_100%_30accu_10s_point 1 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)