$re = '/(BAPN)|(NOBAPN)/';
$str = 'D14 J4N4-BAPN_633nm_20x_100%_30accu_10s_point 1 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);