// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(BAPN)|(NOBAPN)").unwrap();
let string = "D14 J4N4-BAPN_633nm_20x_100%_30accu_10s_point 1 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}