const regex = /(BAPN)|(NOBAPN)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(BAPN)|(NOBAPN)', 'g')
const str = `D14 J4N4-BAPN_633nm_20x_100%_30accu_10s_point 1 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3 D14 J4N5-NOBAPN_633nm_20x_100%_30accu_10s_point 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}