# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+//gu;t' <<< "12121212ABDHSتشؤآئ۳۳۴۳۴729384234owiswoisw"