$re = '/\d+/u';
$str = '12121212ABDHSتشؤآئ۳۳۴۳۴729384234owiswoisw';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;