use strict;
my $str = '12121212ABDHSتشؤآئ۳۳۴۳۴729384234owiswoisw';
my $regex = qr/\d+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";