re = /\d+/
str = '12121212ABDHSتشؤآئ۳۳۴۳۴729384234owiswoisw'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result