using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\|]+)(\s\|)(.*)$";
string substitution = @"\1";
string input = @"HlavnĂ kategorie | Podkategorie | Kategorie na konci ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}