re = /^([^\|]+)(\s\|)(.*)$/mi
str = 'HlavnĂ kategorie | Podkategorie | Kategorie na konci '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result