import re
regex = re.compile(r"^([^\|]+)(\s\|)(.*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = "HlavnĂ kategorie | Podkategorie | Kategorie na konci "
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)