use strict;
my $str = 'Hlavní kategorie | Podkategorie | Kategorie na konci ';
my $regex = qr/^([^\|]+)(\s\|)(.*)$/mip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";