const regex = new RegExp('^([^\\|]+)(\\s\\|)(.*)$', 'gmi')
const str = `HlavnĂ kategorie | Podkategorie | Kategorie na konci `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);