#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:_*[A-Za-z0-9]_*){4,}$"
Local $sString = "hello99____" & @CRLF & _
"abcd" & @CRLF & _
"_a_b_c_d" & @CRLF & _
"_a_b_c_d_" & @CRLF & _
"_a_b_c_d_e" & @CRLF & _
"____abcd" & @CRLF & _
"abcd____" & @CRLF & _
"" & @CRLF & _
"___h8" & @CRLF & _
"bcd____" & @CRLF & _
"____a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")