$re = '/^(?:_*[A-Za-z0-9]_*){4,}$/m';
$str = 'hello99____
abcd
_a_b_c_d
_a_b_c_d_
_a_b_c_d_e
____abcd
abcd____
___h8
bcd____
____a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);