const regex = /^(?:_*[A-Za-z0-9]_*){4,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:_*[A-Za-z0-9]_*){4,}$', 'gm')
const str = `hello99____
abcd
_a_b_c_d
_a_b_c_d_
_a_b_c_d_e
____abcd
abcd____
___h8
bcd____
____a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}