package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(\/?)(html|head|body)[>\s]([^>]*)>?`)
var str = `<header class="">
<header>
<head class=">
<head>
<head><div>
<head ><div>
<head > <div>
<head ><!--`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}