re = /<(\/?)(html|head|body)[>\s]([^>]*)>?/
str = '<header class="">
<header>
<head class=">
<head>
<head><div>
<head ><div>
<head > <div>
<head ><!--'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end