$re = '/<(\/?)(html|head|body)[>\s]([^>]*)>?/';
$str = '<header class="">
<header>
<head class=">
<head>
<head><div>
<head ><div>
<head > <div>
<head ><!--';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);