#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:\d{1,3},(?:\d{3},)*\d{3})|(?:\d{1,3}))$"
Local $sString = "match:" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1,234" & @CRLF & _
"12,345" & @CRLF & _
"123,456" & @CRLF & _
"1,234,567" & @CRLF & _
"12,345,678" & @CRLF & _
"123,456,789" & @CRLF & _
"" & @CRLF & _
"no match:" & @CRLF & _
"1,2" & @CRLF & _
"1234,567" & @CRLF & _
"1,2,3,4" & @CRLF & _
"123456789" & @CRLF & _
"12,34,567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")