import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\d{1,3},(?:\\d{3},)*\\d{3})|(?:\\d{1,3}))$";
final String string = "match:\n"
+ "1\n"
+ "12\n"
+ "123\n"
+ "1,234\n"
+ "12,345\n"
+ "123,456\n"
+ "1,234,567\n"
+ "12,345,678\n"
+ "123,456,789\n\n"
+ "no match:\n"
+ "1,2\n"
+ "1234,567\n"
+ "1,2,3,4\n"
+ "123456789\n"
+ "12,34,567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}