package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\d{1,3},(?:\d{3},)*\d{3})|(?:\d{1,3}))$`)
var str = `match:
1
12
123
1,234
12,345
123,456
1,234,567
12,345,678
123,456,789
no match:
1,2
1234,567
1,2,3,4
123456789
12,34,567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}