const regex = new RegExp('^((?:\\d{1,3},(?:\\d{3},)*\\d{3})|(?:\\d{1,3}))$', 'gm')
const str = `match:
1
12
123
1,234
12,345
123,456
1,234,567
12,345,678
123,456,789
no match:
1,2
1234,567
1,2,3,4
123456789
12,34,567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}