$re = '/^((?:\d{1,3},(?:\d{3},)*\d{3})|(?:\d{1,3}))$/m';
$str = 'match:
1
12
123
1,234
12,345
123,456
1,234,567
12,345,678
123,456,789
no match:
1,2
1234,567
1,2,3,4
123456789
12,34,567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);