#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?:new\sMyClass\(new\sAnotherClass\(\).*?\))"
Local $sString = "return new MyClass(constructor, options, ...);" & @CRLF & _
"" & @CRLF & _
"# case 1" & @CRLF & _
"var mc = new MyClass();" & @CRLF & _
"# case 2" & @CRLF & _
"var mc = new MyClass(new AnotherClass());" & @CRLF & _
"# case 3" & @CRLF & _
"var amc = new MyClass(options, new AnotherClass(), ...);" & @CRLF & _
"" & @CRLF & _
"# case 4" & @CRLF & _
"MyClass mc = new MyClass(" & @CRLF & _
" something" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"# case 5" & @CRLF & _
"MyClass mc = new MyClass(" & @CRLF & _
" new AnotherClass()" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"# case 6" & @CRLF & _
"MyClass mc = new MyClass(" & @CRLF & _
" options, new AnotherClass()" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"# case 7" & @CRLF & _
"var amc = new MyClass(new AnotherClass(), options, ...);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")