use strict;
my $str = 'return new MyClass(constructor, options, ...);
# case 1
var mc = new MyClass();
# case 2
var mc = new MyClass(new AnotherClass());
# case 3
var amc = new MyClass(options, new AnotherClass(), ...);
# case 4
MyClass mc = new MyClass(
something
);
# case 5
MyClass mc = new MyClass(
new AnotherClass()
);
# case 6
MyClass mc = new MyClass(
options, new AnotherClass()
);
# case 7
var amc = new MyClass(new AnotherClass(), options, ...);';
my $regex = qr`(?s)(?:new\sMyClass\(new\sAnotherClass\(\).*?\))`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}