import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:new\\sMyClass\\(new\\sAnotherClass\\(\\).*?\\))";
final String string = "return new MyClass(constructor, options, ...);\n\n"
+ "# case 1\n"
+ "var mc = new MyClass();\n"
+ "# case 2\n"
+ "var mc = new MyClass(new AnotherClass());\n"
+ "# case 3\n"
+ "var amc = new MyClass(options, new AnotherClass(), ...);\n\n"
+ "# case 4\n"
+ "MyClass mc = new MyClass(\n"
+ " something\n"
+ ");\n\n"
+ "# case 5\n"
+ "MyClass mc = new MyClass(\n"
+ " new AnotherClass()\n"
+ ");\n\n"
+ "# case 6\n"
+ "MyClass mc = new MyClass(\n"
+ " options, new AnotherClass()\n"
+ ");\n\n"
+ "# case 7\n"
+ "var amc = new MyClass(new AnotherClass(), options, ...);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}