# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(?:new\sMyClass\(new\sAnotherClass\(\).*?\))"
test_str = ("return new MyClass(constructor, options, ...);\n\n"
"# case 1\n"
"var mc = new MyClass();\n"
"# case 2\n"
"var mc = new MyClass(new AnotherClass());\n"
"# case 3\n"
"var amc = new MyClass(options, new AnotherClass(), ...);\n\n"
"# case 4\n"
"MyClass mc = new MyClass(\n"
" something\n"
");\n\n"
"# case 5\n"
"MyClass mc = new MyClass(\n"
" new AnotherClass()\n"
");\n\n"
"# case 6\n"
"MyClass mc = new MyClass(\n"
" options, new AnotherClass()\n"
");\n\n"
"# case 7\n"
"var amc = new MyClass(new AnotherClass(), options, ...);")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.