package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-z_0-9_a-z]+)\.([A-z_0-9_a-z]+)@([a-z]+)\.([a-z]+)\.([a-z]+)$`)
var str = `karre.kamal@st.niituniversity.in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}