const regex = /^([A-z_0-9_a-z]+)\.([A-z_0-9_a-z]+)@([a-z]+)\.([a-z]+)\.([a-z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-z_0-9_a-z]+)\\.([A-z_0-9_a-z]+)@([a-z]+)\\.([a-z]+)\\.([a-z]+)$', 'gm')
const str = `karre.kamal@st.niituniversity.in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}