// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-z_0-9_a-z]+)\.([A-z_0-9_a-z]+)@([a-z]+)\.([a-z]+)\.([a-z]+)$").unwrap();
let string = "karre.kamal@st.niituniversity.in";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}