re = /^([A-z_0-9_a-z]+)\.([A-z_0-9_a-z]+)@([a-z]+)\.([a-z]+)\.([a-z]+)$/m
str = 'karre.kamal@st.niituniversity.in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end