#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$"
Local $sString = "M1 5AA" & @CRLF & _
"M12 5AA" & @CRLF & _
"BL1 5AA" & @CRLF & _
"BL12 5AA" & @CRLF & _
"M1K 5AA" & @CRLF & _
"BL1K 5AA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")