re = /^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$/m
str = 'M1 5AA
M12 5AA
BL1 5AA
BL12 5AA
M1K 5AA
BL1K 5AA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end