const regex = /^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$', 'gm')
const str = `M1 5AA
M12 5AA
BL1 5AA
BL12 5AA
M1K 5AA
BL1K 5AA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}