import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((BL[0-9]{1,2})|((BL[0-9][A-Z])|((M[0-9]{1,2})|((M[0-9][A-Z])|((OL[0-9]{1,2})|((OL[0-9][A-Z])|((SK[0-9]{1,2})|((SK[0-9][A-Z])|((WA[0-9]{1,2})|((WA[0-9][A-Z])|((WN[0-9]{1,2}|((WN[0-9][A-Z])))))))))))))) [0-9][A-Z]{2}$";
final String string = "M1 5AA\n"
+ "M12 5AA\n"
+ "BL1 5AA\n"
+ "BL12 5AA\n"
+ "M1K 5AA\n"
+ "BL1K 5AA\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}