#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=\/\*!BANNERSTART)(?!BANNEREND\*\/(?:\\n){0,2})[\s\S]*?"
Local $sString = "/*!BANNERSTART " & @CRLF & _
"|==============================================================================" & @CRLF & _
"| Информация о дистрибутиве : Freshbroccoli " & @CRLF & _
"|==============================================================================" & @CRLF & _
"| " & @CRLF & _
"| Версия: 0.0.1 " & @CRLF & _
"| Лицензия: ISC " & @CRLF & _
"| Описание: Свежий, переосмысленный сайт Freshbroccoli " & @CRLF & _
"| Компания: ООО БРОККОЛИ " & @CRLF & _
"| Локация: Россия, Москва, 2-я Звенигородская 13/43 " & @CRLF & _
"| Email: info@freshbroccoli.ru " & @CRLF & _
"| Телефон: +7(495)108-07-98 " & @CRLF & _
"| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) " & @CRLF & _
"| " & @CRLF & _
"|------------------------------------------------------------------------------" & @CRLF & _
"| " & @CRLF & _
"| Автор: Андрей Дьяченко (Front-end разработчик) " & @CRLF & _
"| Локация: Россия, Москва " & @CRLF & _
"| Email: a.dyachenko@freshbroccoli.ru " & @CRLF & _
"| Skype: tux_will " & @CRLF & _
"| " & @CRLF & _
"|==============================================================================" & @CRLF & _
"BANNEREND*/" & @CRLF & _
"/*!BANNERSTART " & @CRLF & _
"|==============================================================================" & @CRLF & _
"| Информация о дистрибутиве : Freshbroccoli " & @CRLF & _
"|==============================================================================" & @CRLF & _
"| " & @CRLF & _
"| Версия: 0.0.1 " & @CRLF & _
"| Лицензия: ISC " & @CRLF & _
"| Описание: Свежий, переосмысленный сайт Freshbroccoli " & @CRLF & _
"| Компания: ООО БРОККОЛИ " & @CRLF & _
"| Локация: Россия, Москва, 2-я Звенигородская 13/43 " & @CRLF & _
"| Email: info@freshbroccoli.ru " & @CRLF & _
"| Телефон: +7(495)108-07-98 " & @CRLF & _
"| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) " & @CRLF & _
"| " & @CRLF & _
"|------------------------------------------------------------------------------" & @CRLF & _
"| " & @CRLF & _
"| Автор: Андрей Дьяченко (Front-end разработчик) " & @CRLF & _
"| Локация: Россия, Москва " & @CRLF & _
"| Email: a.dyachenko@freshbroccoli.ru " & @CRLF & _
"| Skype: tux_will " & @CRLF & _
"| " & @CRLF & _
"|==============================================================================" & @CRLF & _
"BANNEREND*/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")