using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\/\*!BANNERSTART)(?!BANNEREND\*\/(?:\\n){0,2})[\s\S]*?";
string input = @"/*!BANNERSTART
|==============================================================================
| Информация о дистрибутиве : Freshbroccoli
|==============================================================================
|
| Версия: 0.0.1
| Лицензия: ISC
| Описание: Свежий, переосмысленный сайт Freshbroccoli
| Компания: ООО БРОККОЛИ
| Локация: Россия, Москва, 2-я Звенигородская 13/43
| Email: info@freshbroccoli.ru
| Телефон: +7(495)108-07-98
| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK)
|
|------------------------------------------------------------------------------
|
| Автор: Андрей Дьяченко (Front-end разработчик)
| Локация: Россия, Москва
| Email: a.dyachenko@freshbroccoli.ru
| Skype: tux_will
|
|==============================================================================
BANNEREND*/
/*!BANNERSTART
|==============================================================================
| Информация о дистрибутиве : Freshbroccoli
|==============================================================================
|
| Версия: 0.0.1
| Лицензия: ISC
| Описание: Свежий, переосмысленный сайт Freshbroccoli
| Компания: ООО БРОККОЛИ
| Локация: Россия, Москва, 2-я Звенигородская 13/43
| Email: info@freshbroccoli.ru
| Телефон: +7(495)108-07-98
| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK)
|
|------------------------------------------------------------------------------
|
| Автор: Андрей Дьяченко (Front-end разработчик)
| Локация: Россия, Москва
| Email: a.dyachenko@freshbroccoli.ru
| Skype: tux_will
|
|==============================================================================
BANNEREND*/
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}