# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\/\*!BANNERSTART)(?!BANNEREND\*\/(?:\\n){0,2})[\s\S]*?"
test_str = ("/*!BANNERSTART \n"
"|==============================================================================\n"
"| Информация о дистрибутиве : Freshbroccoli \n"
"|==============================================================================\n"
"| \n"
"| Версия: 0.0.1 \n"
"| Лицензия: ISC \n"
"| Описание: Свежий, переосмысленный сайт Freshbroccoli \n"
"| Компания: ООО БРОККОЛИ \n"
"| Локация: Россия, Москва, 2-я Звенигородская 13/43 \n"
"| Email: info@freshbroccoli.ru \n"
"| Телефон: +7(495)108-07-98 \n"
"| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) \n"
"| \n"
"|------------------------------------------------------------------------------\n"
"| \n"
"| Автор: Андрей Дьяченко (Front-end разработчик) \n"
"| Локация: Россия, Москва \n"
"| Email: a.dyachenko@freshbroccoli.ru \n"
"| Skype: tux_will \n"
"| \n"
"|==============================================================================\n"
"BANNEREND*/\n"
"/*!BANNERSTART \n"
"|==============================================================================\n"
"| Информация о дистрибутиве : Freshbroccoli \n"
"|==============================================================================\n"
"| \n"
"| Версия: 0.0.1 \n"
"| Лицензия: ISC \n"
"| Описание: Свежий, переосмысленный сайт Freshbroccoli \n"
"| Компания: ООО БРОККОЛИ \n"
"| Локация: Россия, Москва, 2-я Звенигородская 13/43 \n"
"| Email: info@freshbroccoli.ru \n"
"| Телефон: +7(495)108-07-98 \n"
"| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) \n"
"| \n"
"|------------------------------------------------------------------------------\n"
"| \n"
"| Автор: Андрей Дьяченко (Front-end разработчик) \n"
"| Локация: Россия, Москва \n"
"| Email: a.dyachenko@freshbroccoli.ru \n"
"| Skype: tux_will \n"
"| \n"
"|==============================================================================\n"
"BANNEREND*/\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.