use strict;
my $str = '/*!BANNERSTART
|==============================================================================
| Информация о дистрибутиве : Freshbroccoli
|==============================================================================
|
| Версия: 0.0.1
| Лицензия: ISC
| Описание: Свежий, переосмысленный сайт Freshbroccoli
| Компания: ООО БРОККОЛИ
| Локация: Россия, Москва, 2-я Звенигородская 13/43
| Email: info@freshbroccoli.ru
| Телефон: +7(495)108-07-98
| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK)
|
|------------------------------------------------------------------------------
|
| Автор: Андрей Дьяченко (Front-end разработчик)
| Локация: Россия, Москва
| Email: a.dyachenko@freshbroccoli.ru
| Skype: tux_will
|
|==============================================================================
BANNEREND*/
/*!BANNERSTART
|==============================================================================
| Информация о дистрибутиве : Freshbroccoli
|==============================================================================
|
| Версия: 0.0.1
| Лицензия: ISC
| Описание: Свежий, переосмысленный сайт Freshbroccoli
| Компания: ООО БРОККОЛИ
| Локация: Россия, Москва, 2-я Звенигородская 13/43
| Email: info@freshbroccoli.ru
| Телефон: +7(495)108-07-98
| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK)
|
|------------------------------------------------------------------------------
|
| Автор: Андрей Дьяченко (Front-end разработчик)
| Локация: Россия, Москва
| Email: a.dyachenko@freshbroccoli.ru
| Skype: tux_will
|
|==============================================================================
BANNEREND*/
';
my $regex = qr/(?=\/\*!BANNERSTART)(?!BANNEREND\*\/(?:\\n){0,2})[\s\S]*?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}