import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\/\\*!BANNERSTART)(?!BANNEREND\\*\\/(?:\\\\n){0,2})[\\s\\S]*?";
final String string = "/*!BANNERSTART \n"
+ "|==============================================================================\n"
+ "| Информация о дистрибутиве : Freshbroccoli \n"
+ "|==============================================================================\n"
+ "| \n"
+ "| Версия: 0.0.1 \n"
+ "| Лицензия: ISC \n"
+ "| Описание: Свежий, переосмысленный сайт Freshbroccoli \n"
+ "| Компания: ООО БРОККОЛИ \n"
+ "| Локация: Россия, Москва, 2-я Звенигородская 13/43 \n"
+ "| Email: info@freshbroccoli.ru \n"
+ "| Телефон: +7(495)108-07-98 \n"
+ "| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) \n"
+ "| \n"
+ "|------------------------------------------------------------------------------\n"
+ "| \n"
+ "| Автор: Андрей Дьяченко (Front-end разработчик) \n"
+ "| Локация: Россия, Москва \n"
+ "| Email: a.dyachenko@freshbroccoli.ru \n"
+ "| Skype: tux_will \n"
+ "| \n"
+ "|==============================================================================\n"
+ "BANNEREND*/\n"
+ "/*!BANNERSTART \n"
+ "|==============================================================================\n"
+ "| Информация о дистрибутиве : Freshbroccoli \n"
+ "|==============================================================================\n"
+ "| \n"
+ "| Версия: 0.0.1 \n"
+ "| Лицензия: ISC \n"
+ "| Описание: Свежий, переосмысленный сайт Freshbroccoli \n"
+ "| Компания: ООО БРОККОЛИ \n"
+ "| Локация: Россия, Москва, 2-я Звенигородская 13/43 \n"
+ "| Email: info@freshbroccoli.ru \n"
+ "| Телефон: +7(495)108-07-98 \n"
+ "| Файл изменен: Thu Mar 23 2017 17:09:03 GMT+0300 (MSK) \n"
+ "| \n"
+ "|------------------------------------------------------------------------------\n"
+ "| \n"
+ "| Автор: Андрей Дьяченко (Front-end разработчик) \n"
+ "| Локация: Россия, Москва \n"
+ "| Email: a.dyachenko@freshbroccoli.ru \n"
+ "| Skype: tux_will \n"
+ "| \n"
+ "|==============================================================================\n"
+ "BANNEREND*/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}